Goldstar Logo
Your Source for PSQL Database Products, Services and Training Since 1997 EMail: Sales@goldstarsoftware.com 
Phone: 1-708-647-7665 
Web Site Login 
Free PSQL Support
Quick Links
Database Engines
+ Actian Zen v13
+ Actian PSQL v13
+ Actian PSQL v12
+ Actian PSQL v11
+ Pervasive PSQL v10
+ Pervasive PSQL v9
+ Pervasive.SQL V8
+ Pervasive.SQL 2000i
+ Pervasive.SQL 7
+ Btrieve v12
+ Btrieve 6.15

+ Data Protection Products

+ Goldstar Software Services

+ Goldstar Software Tools

+ Other Solutions

AMS Users: Click Me Fix My PSQL License Repair PSQL Files Get Support Now Join Our Mailing List

Navigation Background

Application Support for Service Pro International


Software Vendor: Service Pro International
Application Versions: Current

Important Note from Service Pro International:
At this time, we are discontinuing support for Pervasive database versions older than Pervasive PSQL v9. Please upgrade to Pervasive PSQL Summit v10.

QUICK LINKS FOR PERVASIVE PSQL SUMMIT v10 USERS:
QUICK LINKS FOR PERVASIVE PSQL v9 USERS:

The Service Pro International application uses the Pervasive database engine to provide world-class performance and flexibility to their application development efforts. Users can purchase software through various resellers, including Goldstar Software. We have worked extensively with Pervasive over the years and are in an excellent position to help you get your software installed and running quickly.

Installation of the Pervasive database is easy -- pop in the CDROM & follow the prompts, then reboot, so you can do it yourself or have your tech guy (or gal) handle it for you. There is also a trial download available from the Pervasive web site (see links above) if needed. This trial can be converted to a full license, if you wish to avoid shipping costs of the physical CDROM.

The Pervasive PSQL v10 Server Engine is available with user counts of 6, 10, 20, 50, and higher. The Server Engine requires the use of a Windows 2000/2003/2008 or Linux database/file server (although Linux server may not be a supported Service Pro International configuration), but smaller 6U and 10U systems can also run on Windows Vista and Windows 7. We also recommend making sure that you meet the Pervasive.SQL Pre-Requisites list on your network before upgrading.

If you have questions or need support regarding your Pervasive database, then you have several options. If the problem is within 30 days of your initial purchase, then you may still have one free support incident directly with ther software developer, Pervasive Software. Please contact them at 800-BTRIEVE. If you are having any licensing problems, you should also contact Pervasive Software directly. Beyond this initial period, paid support is also available from Pervasive Software ($500/Incident) or from Goldstar Software ($250/Hour). Goldstar Software can also provide file recovery services to address corrupted files, and we can provide assistance with your backups to help prevent data loss in the first place.

For pricing, please refer to our price list for Pervasive PSQL v10 or call us for an exact quote!

Pervasive PSQL v9 is a discontinued release that became unsupported by Pervasive Software on January 1, 2010. Service Pro International will still provide support for this engine where possible, but an upgrade to a current release may be required if you have major issues or if you upgrade your client workstations. You should be running the latest version, v9.71, which is an updated patch release available directly from Pervasive Software's web site. This release is supported on Windows 98SE or newer, although if you intend to run on Windows Vista, please note that there will be some manual configuration steps. See our Vista Support Page for more information on these steps. PSQLv9 is not recommended for nor supported on Windows 7.

Pervasive PSQL Summit v10 is the best release and is a paid upgrade from older versions. PSQLv10 is ideal if you intend to be running Windows Vista or Windows 7. The PSQLv10 software does NOT support running on Windows 95, 98, ME, or NT, so sites with older computers may be forced to upgrade their operating systems first. Also, please note that Windows 2000 users must have SP4, and Windows XP users must have SP2 to install this release. Users should also obtain the latest patch, indicated above.

While Pervasive PSQL v11 is also available now, Service Pro International has not completed testing on this new release at this time. Users should purchase the older PSQLv10 instead.

Support Matrix:

Workgroup

Server: Windows

Server: Linux

Pervasive.SQL V8 or older NO NO NO
Pervasive PSQL v9 NO YES NO
Pervasive PSQL Summit v10 NO YES/R NO
Pervasive PSQL v11 NO NO NO

*Items with a NO are unsupported; items with YES are supported. Items with R are recommended.

There are a few points of interest:

  1. Performance Tip: If you have a very old system, you may wish to consider upgrading your database files to the v9.5 file format. See our white paper on this topic for more information. If you have a very old database with 5.x files, you may be REQUIRED to rebuild files to maintain compatibility with PSQLv9 or newer.
  2. Status Code 161 After Installation: If you are getting a Status 161 (Licensing Error) after installing Pervasive, then your database license may not be properly applied. Go to the database server and start the Pervasive License Administrator (which you'll find in the Start/Programs/Pervasive programs group) and check the license count showing on this screen. If you do not see a permanent license with the correct user count, then you will need to apply your license. See your invoice or packing slip for your Registration Keycode, and enter this string into the boxes provided, then click "Add License". You should then see the proper license count. See our License Troubleshooting White Paper for more information.
  3. Is Pervasive PSQL v9 supported on Windows Vista? Windows Vista adds a whole new level to the security game. Vista and Windows 7 users should upgrade to Pervasive PSQL Summit v10, which offers native support for these newer operating systems.

If you need help with installing or patching your database engine, Goldstar Software also provides update services via the Internet for a fixed fee. See our Installation Services page for more details. If you are running PeachTree Accounting or other Pervasive applications, then we strongly recommend using our installation services, as PeachTree can make installing a bit more of a challenge.

 

If you are a software vendor and would like to add, remove, or modify your information on these pages, we'll be happy to oblige. Simply contact us directly!

  Copyright © 1997-2017, Goldstar Software Inc., All rights reserved. PRODUCTS | SERVICES | TRAINING | SUPPORT | DOWNLOADS | ABOUT US  
Goldstar Software Inc. | 3007 Carmel Dr | Flossmoor IL 60422 Legal Statements | EULAs | Uninstall | Privacy Statements | Contact Us